Vulnerability · Published Nov 20, 2023 · Assigned by apache
CVE-2022-46337Apache Derby: LDAP injection vulnerability in authenticator
Critical 9.8
In plain English
A critical-severity injection in Apache Derby from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures. Mitigation: Users should upgrade to Java 21 and Derby 10.17.1.0. Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | derby | no fix listed | DEBIAN-CVE-2022-46337 |
| Debian:13 | derby | 10.14.2.0-3 | DEBIAN-CVE-2022-46337 |
| Debian:14 | derby | 10.14.2.0-3 | DEBIAN-CVE-2022-46337 |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | 10.14.2.1 | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | 10.16.1.2 | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | 10.15.2.1 | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Maven | org.apache.derby:derby | no fix listed | GHSA-rcjc-c4pj-xxrp |
| Ubuntu:22.04:LTS | derby | no fix listed | UBUNTU-CVE-2022-46337 |
| Ubuntu:24.04:LTS | derby | no fix listed | UBUNTU-CVE-2022-46337 |
| Ubuntu:25.10 | derby | no fix listed | UBUNTU-CVE-2022-46337 |
| Ubuntu:26.04:LTS | derby | no fix listed | UBUNTU-CVE-2022-46337 |
| Ubuntu:26.10 | derby | no fix listed | UBUNTU-CVE-2022-46337 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Derby | 10.1.1.0 – through 10.1.3.110.2.1.6 – through 10.2.2.010.3.1.4 – through 10.3.3.010.4.1.3 – through 10.4.2.010.5.1.1 – through 10.5.3.010.6.1.0 – through 10.6.2.110.7.1.110.8.1.2 – through 10.8.3.0 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/q23kvvtoohgzwybxpwozmvvk17rp0td3 vendor-advisory