Vulnerability · Published Dec 16, 2022 · Assigned by VulDB
CVE-2022-4556Alinto SOGo Identity SOGoUserDefaults.m _migrateMailIdentities cross site scripting
Low 3.5
In plain English
A low-severity security flaw in SOGo from Alinto. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
A vulnerability was found in Alinto SOGo up to 5.7.1 and classified as problematic. Affected by this issue is the function _migrateMailIdentities of the file SoObjects/SOGo/SOGoUserDefaults.m of the component Identity Handler. The manipulation of the argument fullName leads to cross site scripting. The attack may be launched remotely. Upgrading to version 5.8.0 is able to address this issue. The name of the patch is efac49ae91a4a325df9931e78e543f707a0f8e5e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215960.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | sogo | 5.8.0-1 | DEBIAN-CVE-2022-4556 |
| Debian:13 | sogo | 5.8.0-1 | DEBIAN-CVE-2022-4556 |
Affected products (as reported)
Weakness: CWE-707 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N