Vulnerability · Published Dec 15, 2022 · Assigned by VulDB

CVE-2022-4524Roots soil Plugin CleanUpModule.php language_attributes cross site scripting

Low 3.5

In plain English

A low-severity cross-site scripting in soil Plugin from Roots. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.6%top 51.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistroots/soil4.1.0GHSA-jw6x-4h8h-569x

Affected products (as reported)

VendorProductVersions
Roots soil Plugin 4.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

References