Vulnerability · Published Apr 13, 2023 · Assigned by apache

CVE-2022-45064Apache Sling Engine: Include-based XSS

High 8.0

In plain English

A high-severity cross-site scripting in Apache Sling Engine from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.1%top 33.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.sling:org.apache.sling.engine2.14.0GHSA-mg46-f9h5-g27x

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Sling Engine – before 2.14.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

References