Vulnerability · Published Oct 26, 2022 · Assigned by apache
CVE-2022-43766Apache IoTDB prior to 0.13.3 allows DoS
High 7.5
In plain English
A high-severity uncontrolled resource consumption in Apache IoTDB from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.6%top 24.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.iotdb:flink-tsfile-connector | 0.13.3 | GHSA-g6hg-4v3c-6jq7 |
| Maven | org.apache.iotdb:iotdb-server | 0.13.3 | GHSA-g6hg-4v3c-6jq7 |
| Maven | org.apache.iotdb:tsfile | 0.13.3 | GHSA-g6hg-4v3c-6jq7 |
| PyPI | apache-iotdb | 0.13.3 | GHSA-g6hg-4v3c-6jq7 |
| PyPI | apache-iotdb | 0.13.3 | PYSEC-2022-42972 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache IoTDB | unspecified – through 0.13.20.12.2 – before unspecified |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H