Vulnerability · Published Nov 7, 2022 · Assigned by apache

CVE-2022-42920Apache Commons BCEL prior to 6.6.0 allows producing arbitrary bytecode via out-of-bounds writing

Critical 9.8

In plain English

A critical-severity out-of-bounds write in Apache Commons BCEL from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.5% (higher than 89% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)3.5%top 10.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9bcel6.4.1-9.el9_1ALSA-2023:0005
Debian:12bcel6.5.0-2DEBIAN-CVE-2022-42920
Debian:13bcel6.5.0-2DEBIAN-CVE-2022-42920
Debian:14bcel6.5.0-2DEBIAN-CVE-2022-42920
Mavenorg.apache.bcel:bcel6.6.0GHSA-97xg-phpr-rg8q
Rocky Linux:9bcel0:6.4.1-9.el9_1RLSA-2023:0005
Ubuntu:22.04:LTSbcel6.5.0-1ubuntu0.1USN-7208-1
Ubuntu:22.04:LTSbcel6.5.0-1ubuntu0.1UBUNTU-CVE-2022-42920

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Commons BCEL Apache Commons BCEL – before 6.6.0

Weakness: CWE-787

References