Vulnerability · Published Oct 25, 2022 · Assigned by apache

CVE-2022-42890Apache Batik prior to 1.16 allows RCE via scripting

High 7.5

In plain English

A high-severity security flaw in Apache XML Graphics from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.4% (higher than 89% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)3.4%top 11.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12batik1.16+dfsg-1DEBIAN-CVE-2022-42890
Debian:13batik1.16+dfsg-1DEBIAN-CVE-2022-42890
Debian:14batik1.16+dfsg-1DEBIAN-CVE-2022-42890
Mavenorg.apache.xmlgraphics:batik1.16GHSA-rwqr-m72q-v6cm
Mavenorg.apache.xmlgraphics:batik-bridge1.16GHSA-rwqr-m72q-v6cm
Ubuntu:22.04:LTSbatik1.14-1ubuntu0.2USN-6117-1
Ubuntu:22.04:LTSbatik1.14-1ubuntu0.2UBUNTU-CVE-2022-42890
Ubuntu:24.04:LTSbatikno fix listedUBUNTU-CVE-2022-42890
Ubuntu:25.10batikno fix listedUBUNTU-CVE-2022-42890
Ubuntu:26.04:LTSbatikno fix listedUBUNTU-CVE-2022-42890
Ubuntu:26.10batikno fix listedUBUNTU-CVE-2022-42890

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache XML Graphics Batik – through 1.15

References