Vulnerability · Published Feb 15, 2023 · Assigned by apache
CVE-2022-42735Apache ShenYu Admin ultra vires
High 8.8
In plain English
A high-severity privilege mismanagement in Apache ShenYu from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own. This issue affects Apache ShenYu: 2.5.0. Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958 https://github.com/apache/shenyu/pull/3958 .
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.shenyu:shenyu-admin | 2.5.1 | GHSA-vf8h-2wwj-jq22 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ShenYu | 0 – through 2.5.0 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/2k8764jmckmc19qc8x51nlnngq71pcf7 vendor-advisory