Vulnerability · Published Nov 15, 2022 · Assigned by GitHub_M
CVE-2022-41916Read one byte past a buffer when normalizing Unicode
Medium 5.9
In plain English
A medium-severity security flaw in heimdal from heimdal. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | heimdal | 7.7.1-r0 | ALPINE-CVE-2022-41916 |
| Alpine:v3.21 | heimdal | 7.7.1-r0 | ALPINE-CVE-2022-41916 |
| Alpine:v3.22 | heimdal | 7.7.1-r0 | ALPINE-CVE-2022-41916 |
| Alpine:v3.23 | heimdal | 7.7.1-r0 | ALPINE-CVE-2022-41916 |
| Alpine:v3.24 | heimdal | 7.7.1-r0 | ALPINE-CVE-2022-41916 |
| Debian:12 | heimdal | 7.8.git20221115.a6cf945+dfsg-1 | DEBIAN-CVE-2022-41916 |
| Debian:13 | heimdal | 7.8.git20221115.a6cf945+dfsg-1 | DEBIAN-CVE-2022-41916 |
| Debian:14 | heimdal | 7.8.git20221115.a6cf945+dfsg-1 | DEBIAN-CVE-2022-41916 |
| Ubuntu:22.04:LTS | heimdal | no fix listed | UBUNTU-CVE-2022-41916 |
| Ubuntu:24.04:LTS | heimdal | no fix listed | UBUNTU-CVE-2022-41916 |
| Ubuntu:25.10 | heimdal | no fix listed | UBUNTU-CVE-2022-41916 |
| Ubuntu:26.04:LTS | heimdal | no fix listed | UBUNTU-CVE-2022-41916 |
| Ubuntu:26.10 | heimdal | no fix listed | UBUNTU-CVE-2022-41916 |
Affected products (as reported)
Weakness: CWE-193 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H