Vulnerability · Published Dec 13, 2022 · Assigned by GitHub_M

CVE-2022-41915

Medium 6.5

In plain English

A medium-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.0%top 38.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12netty1:4.1.48-6DEBIAN-CVE-2022-41915
Debian:13netty1:4.1.48-6DEBIAN-CVE-2022-41915
Debian:14netty1:4.1.48-6DEBIAN-CVE-2022-41915
Mavenio.netty:netty-codec-http4.1.86.FinalGHSA-hh82-3pmq-7frp
Ubuntu:22.04:LTSnetty1:4.1.48-4+deb11u1build0.22.04.1USN-6049-1
Ubuntu:22.04:LTSnetty1:4.1.48-4+deb11u1build0.22.04.1UBUNTU-CVE-2022-41915

Affected products (as reported)

VendorProductVersions
netty netty 4.1.86.Final – before 4.1.86.Final4.1.83.Final – before 4.1.83.Final*

Weakness: CWE-436, CWE-113 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

References