Vulnerability · Published Dec 12, 2022 · Assigned by GitHub_M
CVE-2022-41881
Medium 5.3
In plain English
A medium-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | netty | 1:4.1.48-6 | DEBIAN-CVE-2022-41881 |
| Debian:13 | netty | 1:4.1.48-6 | DEBIAN-CVE-2022-41881 |
| Debian:14 | netty | 1:4.1.48-6 | DEBIAN-CVE-2022-41881 |
| Maven | io.netty:netty-codec-haproxy | 4.1.86.Final | GHSA-fx2c-96vj-985v |
| Ubuntu:22.04:LTS | netty | 1:4.1.48-4+deb11u1build0.22.04.1 | USN-6049-1 |
| Ubuntu:22.04:LTS | netty | 1:4.1.48-4+deb11u1build0.22.04.1 | UBUNTU-CVE-2022-41881 |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L