Vulnerability · Published Oct 25, 2022 · Assigned by apache
CVE-2022-41704Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input
High 7.5
In plain English
A high-severity server-side request forgery in Apache XML Graphics from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.1% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)3.1%top 12.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A vulnerability in Batik of Apache XML Graphics allows an attacker to run untrusted Java code from an SVG. This issue affects Apache XML Graphics prior to 1.16. It is recommended to update to version 1.16.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | batik | 1.16+dfsg-1 | DEBIAN-CVE-2022-41704 |
| Debian:13 | batik | 1.16+dfsg-1 | DEBIAN-CVE-2022-41704 |
| Debian:14 | batik | 1.16+dfsg-1 | DEBIAN-CVE-2022-41704 |
| Maven | org.apache.xmlgraphics:batik | 1.16 | GHSA-r29w-r9ph-vm76 |
| Ubuntu:22.04:LTS | batik | 1.14-1ubuntu0.2 | USN-6117-1 |
| Ubuntu:22.04:LTS | batik | 1.14-1ubuntu0.2 | UBUNTU-CVE-2022-41704 |
| Ubuntu:24.04:LTS | batik | no fix listed | UBUNTU-CVE-2022-41704 |
| Ubuntu:25.10 | batik | no fix listed | UBUNTU-CVE-2022-41704 |
| Ubuntu:26.04:LTS | batik | no fix listed | UBUNTU-CVE-2022-41704 |
| Ubuntu:26.10 | batik | no fix listed | UBUNTU-CVE-2022-41704 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache XML Graphics | Batik – through 1.15 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://lists.apache.org/thread/hplhx0o74jb7blj39fm4kw3otcnjd6xf
- [oss-security] 20221025 [CVE-2022-41704] Apache Batik information disclosure vulnerability mailing-list
- [debian-lts-announce] 20221029 [SECURITY] [DLA 3169-1] batik security update mailing-list
- DSA-5264 vendor-advisory
- GLSA-202401-11 vendor-advisory