Vulnerability · Published Dec 25, 2022 · Assigned by mitre

CVE-2022-41318

High 8.6

In plain English

A high-severity integer overflow in the libecap package (AlmaLinux). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.1% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)3.1%top 12.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2022:6775
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2022:6775
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2022:6775
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2022:6775
AlmaLinux:8squid7:4.15-3.module_el8.6.0+3275+7a670b72.2ALSA-2022:6775
AlmaLinux:9squid7:5.2-1.el9_0.2ALSA-2022:6839
Debian:12squid5.7-1DEBIAN-CVE-2022-41318
Debian:13squid5.7-1DEBIAN-CVE-2022-41318
Debian:14squid5.7-1DEBIAN-CVE-2022-41318
Rocky Linux:8libecap0:1.0.1-2.module+el8.4.0+404+316a0dc5RLSA-2022:6775
Rocky Linux:8squid7:4.15-3.module+el8.6.0+1044+67ab5d0a.2RLSA-2022:6775
Rocky Linux:9squid7:5.2-1.el9_0.2RLSA-2022:6839
Ubuntu:22.04:LTSsquid5.2-1ubuntu4.2USN-5641-1
Ubuntu:22.04:LTSsquid5.2-1ubuntu4.2UBUNTU-CVE-2022-41318

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

References