Vulnerability · Published Nov 19, 2022 · Assigned by VulDB

CVE-2022-4064Dalli Meta Protocol request_formatter.rb self.meta_set injection

Low 3.7

In plain English

A low-severity injection in Dalli. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)1.4%top 27.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdalli3.2.3GHSA-3xg8-cc8f-9wv2
Ubuntu:22.04:LTSruby-dallino fix listedUBUNTU-CVE-2022-4064
Ubuntu:24.04:LTSruby-dallino fix listedUBUNTU-CVE-2022-4064
Ubuntu:25.10ruby-dallino fix listedUBUNTU-CVE-2022-4064
Ubuntu:26.04:LTSruby-dallino fix listedUBUNTU-CVE-2022-4064
Ubuntu:26.10ruby-dallino fix listedUBUNTU-CVE-2022-4064

Affected products (as reported)

VendorProductVersions
n/a Dalli 3.2.03.2.13.2.2

Weakness: CWE-74, CWE-707 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References