Vulnerability · Published Sep 20, 2022 · Assigned by NCSC.ch
CVE-2022-39958Response body bypass in OWASP ModSecurity Core Rule Set via repeated HTTP Range header submission with a small byte range
High 7.5
In plain English
A high-severity incorrect authorization in ModSecurity Core Rule Set from OWASP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The OWASP ModSecurity Core Rule Set (CRS) is affected by a response body bypass to sequentially exfiltrate small and undetectable sections of data by repeatedly submitting an HTTP Range header field with a small byte range. A restricted resource, access to which would ordinarily be detected, may be exfiltrated from the backend, despite being protected by a web application firewall that uses CRS. Short subsections of a restricted resource may bypass pattern matching techniques and allow undetected access. The legacy CRS versions 3.0.x and 3.1.x are affected, as well as the currently supported versions 3.2.1 and 3.3.2. Integrators and users are advised to upgrade to 3.2.2 and 3.3.3 respectively and to configure a CRS paranoia level of 3 or higher.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | modsecurity-crs | 3.3.4-1 | DEBIAN-CVE-2022-39958 |
| Debian:13 | modsecurity-crs | 3.3.4-1 | DEBIAN-CVE-2022-39958 |
| Debian:14 | modsecurity-crs | 3.3.4-1 | DEBIAN-CVE-2022-39958 |
| Ubuntu:22.04:LTS | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39958 |
| Ubuntu:24.04:LTS | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39958 |
| Ubuntu:25.10 | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39958 |
| Ubuntu:26.04:LTS | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39958 |
| Ubuntu:26.10 | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39958 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OWASP | ModSecurity Core Rule Set | 3.0.x3.1.xunspecified – through 3.2.1unspecified – through 3.3.2 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://coreruleset.org/20220919/crs-version-3-3-3-and-3-2-2-covering-several-cves/
- FEDORA-2022-90708b46e3 vendor-advisory
- FEDORA-2022-85a85c84b3 vendor-advisory
- FEDORA-2022-1fd73a5285 vendor-advisory
- [debian-lts-announce] 20230130 [SECURITY] [DLA 3293-1] modsecurity-crs security update mailing-list
- GLSA-202305-25 vendor-advisory
- https://lists.debian.org/debian-lts-announce/2025/08/msg00004.html