Vulnerability · Published Sep 20, 2022 · Assigned by NCSC.ch

CVE-2022-39956Partial rule set bypass in OWASP ModSecurity Core Rule Set for HTTP multipart requests using character encoding in the Content-Type or Content-Transfer-Encoding header

High 7.3

In plain English

A high-severity incorrect authorization in ModSecurity Core Rule Set from OWASP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)1.2%top 31.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The OWASP ModSecurity Core Rule Set (CRS) is affected by a partial rule set bypass for HTTP multipart requests by submitting a payload that uses a character encoding scheme via the Content-Type or the deprecated Content-Transfer-Encoding multipart MIME header fields that will not be decoded and inspected by the web application firewall engine and the rule set. The multipart payload will therefore bypass detection. A vulnerable backend that supports these encoding schemes can potentially be exploited. The legacy CRS versions 3.0.x and 3.1.x are affected, as well as the currently supported versions 3.2.1 and 3.3.2. Integrators and users are advised upgrade to 3.2.2 and 3.3.3 respectively. The mitigation against these vulnerabilities depends on the installation of the latest ModSecurity version (v2.9.6 / v3.0.8).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12modsecurity-crs3.3.4-1DEBIAN-CVE-2022-39956
Debian:13modsecurity-crs3.3.4-1DEBIAN-CVE-2022-39956
Debian:14modsecurity-crs3.3.4-1DEBIAN-CVE-2022-39956
Ubuntu:22.04:LTSmodsecurity-crsno fix listedUBUNTU-CVE-2022-39956
Ubuntu:24.04:LTSmodsecurity-crsno fix listedUBUNTU-CVE-2022-39956
Ubuntu:25.10modsecurity-crsno fix listedUBUNTU-CVE-2022-39956
Ubuntu:26.04:LTSmodsecurity-crsno fix listedUBUNTU-CVE-2022-39956
Ubuntu:26.10modsecurity-crsno fix listedUBUNTU-CVE-2022-39956

Affected products (as reported)

VendorProductVersions
OWASP ModSecurity Core Rule Set 3.0.x3.1.xunspecified – through 3.2.1unspecified – through 3.3.2

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References