Vulnerability · Published Sep 20, 2022 · Assigned by NCSC.ch
CVE-2022-39955Partial rule set bypass in OWASP ModSecurity Core Rule Set by submitting a specially crafted HTTP Content-Type header
High 7.3
In plain English
A high-severity incorrect authorization in ModSecurity Core Rule Set from OWASP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The OWASP ModSecurity Core Rule Set (CRS) is affected by a partial rule set bypass by submitting a specially crafted HTTP Content-Type header field that indicates multiple character encoding schemes. A vulnerable back-end can potentially be exploited by declaring multiple Content-Type "charset" names and therefore bypassing the configurable CRS Content-Type header "charset" allow list. An encoded payload can bypass CRS detection this way and may then be decoded by the backend. The legacy CRS versions 3.0.x and 3.1.x are affected, as well as the currently supported versions 3.2.1 and 3.3.2. Integrators and users are advised to upgrade to 3.2.2 and 3.3.3 respectively.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | modsecurity-crs | 3.3.4-1 | DEBIAN-CVE-2022-39955 |
| Debian:13 | modsecurity-crs | 3.3.4-1 | DEBIAN-CVE-2022-39955 |
| Debian:14 | modsecurity-crs | 3.3.4-1 | DEBIAN-CVE-2022-39955 |
| Ubuntu:22.04:LTS | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39955 |
| Ubuntu:24.04:LTS | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39955 |
| Ubuntu:25.10 | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39955 |
| Ubuntu:26.04:LTS | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39955 |
| Ubuntu:26.10 | modsecurity-crs | no fix listed | UBUNTU-CVE-2022-39955 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OWASP | ModSecurity Core Rule Set | 3.0.x3.1.xunspecified – through 3.2.1unspecified – through 3.3.2 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
References
- https://coreruleset.org/20220919/crs-version-3-3-3-and-3-2-2-covering-several-cves/
- FEDORA-2022-90708b46e3 vendor-advisory
- FEDORA-2022-85a85c84b3 vendor-advisory
- FEDORA-2022-1fd73a5285 vendor-advisory
- [debian-lts-announce] 20230130 [SECURITY] [DLA 3293-1] modsecurity-crs security update mailing-list
- GLSA-202305-25 vendor-advisory
- https://lists.debian.org/debian-lts-announce/2025/08/msg00004.html