Vulnerability · Published Nov 2, 2022 · Assigned by GitHub_M

CVE-2022-39379Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

Low 3.1

In plain English

A low-severity unsafe deserialization in fluentd from fluent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 45.0% (higher than 99% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.1Low
Exploit odds (30 days)45.0%top 1.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsfluentd1.15.3GHSA-fppq-mj76-fpj2

Affected products (as reported)

VendorProductVersions
fluent fluentd >= 1.13.2, < 1.15.3

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

References