Vulnerability · Published Oct 26, 2022 · Assigned by GitHub_M

CVE-2022-39362Metabase vulnerable to arbitrary SQL execution from queryhash

High 8.8

In plain English

A high-severity security flaw in metabase from metabase. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities).

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.0%top 36.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, unsaved SQL queries are auto-executed, which could pose a possible attack vector. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer automatically executes ad-hoc native queries. Now the native editor shows the query and gives the user the option to manually run the query if they want.

Affected products (as reported)

VendorProductVersions
metabase metabase < 0.41.9>= 0.42.0, < 0.42.6>= 0.43.0, < 0.43.7>= 0.44.0, < 0.44.5>= 1.0.0, < 1.41.9>= 1.42.0, < 1.42.6>= 1.43.0, < 1.43.7>= 1.44.0, < 1.44.5

Weakness: CWE-356 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References