Vulnerability · Published Nov 25, 2022 · Assigned by GitHub_M
CVE-2022-39346Missing length validation of user displayname in nextcloud server
Low 3.5
In plain English
A low-severity uncontrolled resource consumption in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities).
Official description
Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 22.2.10>= 23.0.0, < 23.0.7>= 24.0.0, < 24.0.3 |
Weakness: CWE-400, CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L