Vulnerability · Published Nov 25, 2022 · Assigned by GitHub_M
CVE-2022-39332Cross-site scripting (XSS) in Nextcloud Desktop Client
Medium 4.6
In plain English
A medium-severity cross-site scripting in security-advisories from nextcloud. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Nexcloud desktop is the Desktop sync client for Nextcloud. An attacker can inject arbitrary HyperText Markup Language into the Desktop Client application via user status and information. It is recommended that the Nextcloud Desktop client is upgraded to 3.6.1. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | nextcloud-desktop | 3.6.1-1 | DEBIAN-CVE-2022-39332 |
| Debian:13 | nextcloud-desktop | 3.6.1-1 | DEBIAN-CVE-2022-39332 |
| Debian:14 | nextcloud-desktop | 3.6.1-1 | DEBIAN-CVE-2022-39332 |
| Ubuntu:22.04:LTS | nextcloud-desktop | no fix listed | UBUNTU-CVE-2022-39332 |
| Ubuntu:24.04:LTS | nextcloud-desktop | no fix listed | UBUNTU-CVE-2022-39332 |
| Ubuntu:25.10 | nextcloud-desktop | no fix listed | UBUNTU-CVE-2022-39332 |
| Ubuntu:26.04:LTS | nextcloud-desktop | no fix listed | UBUNTU-CVE-2022-39332 |
| Ubuntu:26.10 | nextcloud-desktop | no fix listed | UBUNTU-CVE-2022-39332 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 3.6.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N