Vulnerability · Published Oct 25, 2022 · Assigned by GitHub_M
CVE-2022-39315Kirby CMS vulnerable to user enumeration in the brute force protection
Medium 6.5
In plain English
A medium-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | getkirby/cms | 3.5.8.2 | GHSA-c27j-76xg-6x4f |
| Packagist | getkirby/cms | 3.6.6.2 | GHSA-c27j-76xg-6x4f |
| Packagist | getkirby/cms | 3.7.5.1 | GHSA-c27j-76xg-6x4f |
| Packagist | getkirby/cms | 3.8.1 | GHSA-c27j-76xg-6x4f |
Affected products (as reported)
Weakness: CWE-204 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N