Vulnerability · Published Oct 24, 2022 · Assigned by GitHub_M
CVE-2022-39314User enumeration in the code-based login and password reset forms
Medium 4.8
In plain English
A medium-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | getkirby/cms | 3.5.8.2 | GHSA-43qq-qw4x-28f8 |
| Packagist | getkirby/cms | 3.6.6.2 | GHSA-43qq-qw4x-28f8 |
| Packagist | getkirby/cms | 3.7.5.1 | GHSA-43qq-qw4x-28f8 |
| Packagist | getkirby/cms | 3.8.1 | GHSA-43qq-qw4x-28f8 |
Affected products (as reported)
Weakness: CWE-307 · Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/getkirby/kirby/security/advisories/GHSA-43qq-qw4x-28f8 x_refsource_CONFIRM