Vulnerability · Published Oct 13, 2022 · Assigned by GitHub_M

CVE-2022-39300Signature bypass via multiple root elements in node-SAML

High 7.7

In plain English

A high-severity security flaw in node-saml from node-saml. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.8%top 43.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

node SAML is a SAML 2.0 library based on the SAML implementation of passport-saml. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to node-saml version 4.0.0-beta5 or newer. Disabling SAML authentication may be done as a workaround.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmnode-saml4.0.0-beta.5GHSA-5p8w-2mvw-38pv

Affected products (as reported)

VendorProductVersions
node-saml node-saml < 4.0.0-beta.5

Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

References