Vulnerability · Published Oct 6, 2022 · Assigned by GitHub_M
CVE-2022-39280Regular expression denial of service in dparse
Medium 5.9
In plain English
A medium-severity uncontrolled resource consumption in dparse from pyupio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | dparse | 0.5.2 | GHSA-8fg9-p83m-x5pq |
| PyPI | dparse | 0.5.2 | PYSEC-2022-301 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS
- https://github.com/pyupio/dparse/security/advisories/GHSA-8fg9-p83m-x5pq
- https://github.com/pyupio/dparse/commit/8c990170bbd6c0cf212f1151e9025486556062d5
- https://github.com/pyupio/dparse/commit/d87364f9db9ab916451b1b036cfeb039e726e614