Vulnerability · Published Oct 21, 2022 · Assigned by GitHub_M
CVE-2022-39272Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration
Medium 5.0
In plain English
A medium-severity security flaw in flux2 from fluxcd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flux is an open and extensible continuous delivery solution for Kubernetes. Versions prior to 0.35.0 are subject to a Denial of Service. Users that have permissions to change Flux’s objects, either through a Flux source or directly within a cluster, can provide invalid data to fields `.spec.interval` or `.spec.timeout` (and structured variations of these fields), causing the entire object type to stop being processed. This issue is patched in version 0.35.0. As a workaround, Admission controllers can be employed to restrict the values that can be used for fields `.spec.interval` and `.spec.timeout`, however upgrading to the latest versions is still the recommended mitigation.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | flux | 0.36.0-r0 | ALPINE-CVE-2022-39272 |
| Alpine:v3.22 | flux | 0.36.0-r0 | ALPINE-CVE-2022-39272 |
| Alpine:v3.23 | flux | 0.36.0-r0 | ALPINE-CVE-2022-39272 |
| Alpine:v3.24 | flux | 0.36.0-r0 | ALPINE-CVE-2022-39272 |
| Go | github.com/fluxcd/flux2 | 0.35.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/helm-controller | 0.24.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/helm-controller/api | 0.26.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/helm-controller/api | 0.26.0 | GO-2022-1071 |
| Go | github.com/fluxcd/image-automation-controller | 0.26.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/image-automation-controller/api | 0.26.1 | GO-2022-1071 |
| Go | github.com/fluxcd/image-automation-controller/api | 0.26.1 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/image-reflector-controller | 0.22.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/image-reflector-controller/api | 0.22.1 | GO-2022-1071 |
| Go | github.com/fluxcd/image-reflector-controller/api | 0.22.1 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/kustomize-controller | 0.29.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/kustomize-controller/api | 0.30.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/kustomize-controller/api | 0.30.0 | GO-2022-1071 |
| Go | github.com/fluxcd/notification-controller | 0.27.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/notification-controller/api | 0.28.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/notification-controller/api | 0.28.0 | GO-2022-1071 |
| Go | github.com/fluxcd/source-controller | 0.30.0 | GHSA-f4p5-x4vc-mh4v |
| Go | github.com/fluxcd/source-controller/api | 0.30.0 | GO-2022-1071 |
| Go | github.com/fluxcd/source-controller/api | 0.30.0 | GHSA-f4p5-x4vc-mh4v |
Affected products (as reported)
Weakness: CWE-1284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L