Vulnerability · Published Oct 21, 2022 · Assigned by GitHub_M

CVE-2022-39259Jadx-gui subject to Denial of Service via Swing HTML rendering

Low 3.3

In plain English

A low-severity improper input validation in jadx from skylot. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.3Low
Exploit odds (30 days)0.3%top 73.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

jadx is a set of command line and GUI tools for producing Java source code from Android Dex and Apk files. versions prior to 1.4.5 are subject to a Denial of Service when opening zip files with HTML sequences. This issue has been patched in version 1.4.5. There are no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenio.github.skylot:jadx-plugins-api1.4.5GHSA-3r7j-8mqh-6qhx

Affected products (as reported)

VendorProductVersions
skylot jadx < 1.4.5

Weakness: CWE-20 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References