Vulnerability · Published Sep 23, 2022 · Assigned by GitHub_M
CVE-2022-39238Improper Authentication in Arvados when using PAM as identity provider
Medium 4.2
In plain English
A medium-severity improper authentication in arvados from arvados. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
Arvados is an open source platform for managing and analyzing biomedical big data. In versions prior to 2.4.3, when using Portable Authentication Modules (PAM) for user authentication, if a user presented valid credentials but the account is disabled or otherwise not allowed to access the host (such as an expired password), it would still be accepted for access to Arvados. Other authentication methods (LDAP, OpenID Connect) supported by Arvados are not affected by this flaw. This issue is patched in version 2.4.3. Workaround for this issue is to migrate to a different authentication method supported by Arvados, such as LDAP.
Affected products (as reported)
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/arvados/arvados/security/advisories/GHSA-87jr-xwhg-cxjv x_refsource_CONFIRM