Vulnerability · Published Sep 23, 2022 · Assigned by GitHub_M

CVE-2022-39230Security issue in fhir-works-on-aws-authz-smart

Medium 6.5

In plain English

A medium-severity information exposure in fhir-works-on-aws-authz-smart from awslabs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.7%top 45.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmfhir-works-on-aws-authz-smart3.1.3GHSA-vv7x-7w4m-q72f

Affected products (as reported)

VendorProductVersions
awslabs fhir-works-on-aws-authz-smart > 3.1.0, < 3.1.3

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References