Vulnerability · Published Sep 12, 2022 · Assigned by mitre
CVE-2022-37734
High 7.5
In plain English
A high-severity security flaw in the com.graphql-java:graphql-java package (Maven). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.8% (higher than 86% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)2.8%top 13.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.graphql-java:graphql-java | 17.4 | GHSA-v62j-cxhh-fq22 |
| Maven | com.graphql-java:graphql-java | 18.3 | GHSA-v62j-cxhh-fq22 |
Affected products (as reported)
References
- https://github.com/graphql-java/graphql-java/issues/2888 x_refsource_MISC
- https://github.com/graphql-java/graphql-java/pull/2892 x_refsource_MISC
- https://github.com/graphql-java/graphql-java/discussions/2958 x_refsource_CONFIRM
- https://github.com/graphql-java/graphql-java/releases x_refsource_CONFIRM