Vulnerability · Published Aug 31, 2022 · Assigned by apache
CVE-2022-37022Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11
High 8.8
In plain English
A high-severity unsafe deserialization in Apache Geode from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.geode:geode-core | 1.15.0 | GHSA-qf8g-vpwp-6579 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Geode | Apache Geode – through 1.12.2 |
Weakness: CWE-502
References
- https://lists.apache.org/thread/kr1y4l9752g1ww1shnmh8dbfjq785k4m x_refsource_MISC