Vulnerability · Published Aug 31, 2022 · Assigned by apache

CVE-2022-37021Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.

Critical 9.8

In plain English

A critical-severity unsafe deserialization in Apache Geode from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 86% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)2.6%top 14.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.geode:geode-core1.12.16GHSA-q4q3-r45f-7gwg
Mavenorg.apache.geode:geode-core1.13.5GHSA-q4q3-r45f-7gwg
Mavenorg.apache.geode:geode-core1.14.1GHSA-q4q3-r45f-7gwg

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Geode Apache Geode – through 1.12.5

Weakness: CWE-502

References