Vulnerability · Published Aug 9, 2022 · Assigned by apache

CVE-2022-36125Integer overflow when reading corrupted .avro file in Avro Rust SDK

High 7.5

In plain English

A high-severity improper input validation in Apache Avro from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities).

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.6%top 24.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

It is possible to crash (panic) an application by providing a corrupted data to be read. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Avro unspecified – before 0.14.0

Weakness: CWE-20, CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References