Vulnerability · Published Sep 9, 2022 · Assigned by GitHub_M
CVE-2022-36110Netmaker vulnerable to Insufficient Granularity of Access Control
High 8.8
In plain English
A high-severity security flaw in netmaker from gravitl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/gravitl/netmaker | 0.15.1 | GHSA-ggf6-638m-vqmg |
| Go | github.com/gravitl/netmaker | 0.15.1 | GO-2022-0986 |
Affected products (as reported)
Weakness: CWE-1220, CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg x_refsource_CONFIRM
- https://github.com/gravitl/netmaker/releases/tag/v0.15.1 x_refsource_MISC