Vulnerability · Published Sep 8, 2022 · Assigned by GitHub_M

CVE-2022-36096XWiki Platform vulnerable to Cross-site Scripting in the deleted attachments list

High 8.9

In plain English

A high-severity cross-site scripting in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 60.2% (higher than 99.1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.9High
Exploit odds (30 days)60.2%top 0.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and attachments for XWiki Platform, a generic wiki platform. Prior to versions 13.10.6 and 14.3, it's possible to store JavaScript which will be executed by anyone viewing the deleted attachments index with an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3. As a workaround, modify fix the vulnerability by editing the wiki page `XWiki.DeletedAttachments` with the object editor, open the `JavaScriptExtension` object and apply on the content the changes that can be found on the fix commit.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-index-ui13.10.6GHSA-gjmq-x5x7-wc36
Mavenorg.xwiki.platform:xwiki-platform-index-ui14.3GHSA-gjmq-x5x7-wc36

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform >= 2.2-milestone-1, < 13.10.6>= 14.0, < 14.3

Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L

References