Vulnerability · Published Sep 15, 2022 · Assigned by GitHub_M
CVE-2022-36074Authentication headers exposed on by Nextcloud Server
Medium 6.4
In plain English
A medium-severity information exposure in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities).
Official description
Nextcloud server is an open source personal cloud product. Affected versions of this package are vulnerable to Information Exposure which fails to strip the Authorization header on HTTP downgrade. This can lead to account access exposure and compromise. It is recommended that the Nextcloud Server is upgraded to 23.0.7 or 24.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.11, 23.0.7 or 24.0.3. There are no known workarounds for this issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 23.0.7>= 24.0.0, < 24.0.3 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vqgm-f748-g76v x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/32941 x_refsource_MISC