Vulnerability · Published Sep 29, 2022 · Assigned by GitHub_M
CVE-2022-36068Discourse moderators can edit themes via the API
High 7.2
In plain English
A high-severity missing authorization in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities).
Official description
Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a moderator can create new and edit existing themes by using the API when they should not be able to do so. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/discourse/discourse/security/advisories/GHSA-6crr-3662-263q x_refsource_CONFIRM
- https://github.com/discourse/discourse/pull/18418 x_refsource_MISC
- https://github.com/discourse/discourse/commit/ae1e536e83940d58f1c79b835c75c249121c46b6 x_refsource_MISC