Vulnerability · Published Aug 18, 2022 · Assigned by GitHub_M

CVE-2022-36023Remote denial of service in Hyperledger Fabric Gateway

High 7.0

In plain English

A high-severity improper input validation in fabric from hyperledger. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)1.2%top 32.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/hyperledger/fabric2.4.6GHSA-qj6r-fhrc-jj5r

Affected products (as reported)

VendorProductVersions
hyperledger fabric < 2.4.6

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H

References