Vulnerability · Published Nov 1, 2022 · Assigned by openssl

CVE-2022-3602X.509 Email Address 4-byte Buffer Overflow

High 7.5

In plain English

A high-severity out-of-bounds write in OpenSSL from OpenSSL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 90.8% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)90.8%top 0.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects. Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9openssl1:3.0.1-43.el9_0ALSA-2022:7288
AlmaLinux:9openssl-devel1:3.0.1-43.el9_0ALSA-2022:7288
AlmaLinux:9openssl-libs1:3.0.1-43.el9_0ALSA-2022:7288
AlmaLinux:9openssl-perl1:3.0.1-43.el9_0ALSA-2022:7288
Alpine:v3.20nodejs18.12.1-r0ALPINE-CVE-2022-3602
Alpine:v3.21nodejs18.12.1-r0ALPINE-CVE-2022-3602
Alpine:v3.22nodejs18.12.1-r0ALPINE-CVE-2022-3602
Alpine:v3.23nodejs18.12.1-r0ALPINE-CVE-2022-3602
Alpine:v3.24nodejs18.12.1-r0ALPINE-CVE-2022-3602
Alpine:v3.20openssl3.0.7-r0ALPINE-CVE-2022-3602
Alpine:v3.21openssl3.0.7-r0ALPINE-CVE-2022-3602
Alpine:v3.22openssl3.0.7-r0ALPINE-CVE-2022-3602
Alpine:v3.23openssl3.0.7-r0ALPINE-CVE-2022-3602
Alpine:v3.24openssl3.0.7-r0ALPINE-CVE-2022-3602
Debian:12openssl3.0.7-1DEBIAN-CVE-2022-3602
Debian:13openssl3.0.7-1DEBIAN-CVE-2022-3602
Debian:14openssl3.0.7-1DEBIAN-CVE-2022-3602
Rocky Linux:9openssl1:3.0.1-43.el9_0RLSA-2022:7288
Ubuntu:22.04:LTSopenssl3.0.2-0ubuntu1.7UBUNTU-CVE-2022-3602
Ubuntu:22.04:LTSopenssl3.0.2-0ubuntu1.7USN-5710-1

Affected products (as reported)

VendorProductVersions
OpenSSL OpenSSL Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6)

Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References