Vulnerability · Published Aug 1, 2022 · Assigned by GitHub_M
CVE-2022-35921User preference to prevent private discussions not respected in fof/byobu
Low 3.5
In plain English
A low-severity privilege mismanagement in byobu from FriendsOfFlarum. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | fof/byobu | 1.1.7 | GHSA-6gjm-6wj6-4px5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FriendsOfFlarum | byobu | >=0.3.0-beta.2, < 1.1.7 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N