Vulnerability · Published Aug 9, 2022 · Assigned by apache
CVE-2022-35724Denial of service while reading data in Avro Rust SDK
High 7.5
In plain English
A high-severity improper input validation in Apache Avro from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities).
Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.8%top 21.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
It is possible to provide data to be read that leads the reader to loop in cycles endlessly, consuming CPU. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Avro | unspecified – before 0.14.0 |
Weakness: CWE-20, CWE-770
References
- https://lists.apache.org/thread/771z1nwrpkn1ovmyfb2fm65mchdxgy7p x_refsource_MISC