Vulnerability · Published Jul 25, 2022 · Assigned by fedora

CVE-2022-35650

High 7.5

In plain English

A high-severity path traversal in Moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 53.7% (higher than 99.0% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)53.7%top 1.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.9.15GHSA-pgm5-cr62-prxq
Packagistmoodle/moodle3.11.8GHSA-pgm5-cr62-prxq
Packagistmoodle/moodle4.0.2GHSA-pgm5-cr62-prxq

Affected products (as reported)

VendorProductVersions
n/a Moodle Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15

Weakness: CWE-22

References