Vulnerability · Published Jul 25, 2022 · Assigned by fedora

CVE-2022-35649

Critical 9.8

In plain English

A critical-severity code injection in Moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 8.6% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)8.6%top 4.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.9.15GHSA-xp2f-9mx3-3c6p
Packagistmoodle/moodle3.11.8GHSA-xp2f-9mx3-3c6p
Packagistmoodle/moodle4.0.2GHSA-xp2f-9mx3-3c6p

Affected products (as reported)

VendorProductVersions
n/a Moodle Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15

Weakness: CWE-94

References