Vulnerability · Published Jun 18, 2022 · Assigned by mitre

CVE-2022-33987

Medium 5.3

In plain English

A medium-severity security flaw in the nodejs package (AlmaLinux). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.4% (higher than 84% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.3Medium
Exploit odds (30 days)2.4%top 15.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The got package before 12.1.0 (also fixed in 11.8.5) for Node.js allows a redirect to a UNIX socket.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8nodejs1:14.20.0-2.module_el8.6.0+3261+490666b3ALSA-2022:6448
AlmaLinux:9nodejs1:16.16.0-1.el9_0ALSA-2022:6595
AlmaLinux:8nodejs-devel1:14.20.0-2.module_el8.6.0+3261+490666b3ALSA-2022:6448
AlmaLinux:8nodejs-docs1:14.20.0-2.module_el8.6.0+3261+490666b3ALSA-2022:6448
AlmaLinux:9nodejs-docs1:16.16.0-1.el9_0ALSA-2022:6595
AlmaLinux:8nodejs-full-i18n1:14.20.0-2.module_el8.6.0+3261+490666b3ALSA-2022:6448
AlmaLinux:9nodejs-full-i18n1:16.16.0-1.el9_0ALSA-2022:6595
AlmaLinux:9nodejs-libs1:16.16.0-1.el9_0ALSA-2022:6595
AlmaLinux:8nodejs-nodemon2.0.19-2.module_el8.6.0+3261+490666b3ALSA-2022:6448
AlmaLinux:9nodejs-nodemon2.0.19-1.el9_0ALSA-2022:6595
AlmaLinux:8nodejs-packaging23-3.module_el8.5.0+2618+8d46dafdALSA-2022:6448
AlmaLinux:8npm1:6.14.17-1.14.20.0.2.module_el8.6.0+3261+490666b3ALSA-2022:6448
AlmaLinux:9npm1:8.11.0-1.16.16.0.1.el9_0ALSA-2022:6595
Debian:12node-got11.8.3+~cs58.7.37-3DEBIAN-CVE-2022-33987
Debian:13node-got11.8.3+~cs58.7.37-3DEBIAN-CVE-2022-33987
Debian:14node-got11.8.3+~cs58.7.37-3DEBIAN-CVE-2022-33987
Rocky Linux:8nodejs1:16.16.0-3.module+el8.6.0+1003+ae94235aRLSA-2022:6449
Rocky Linux:8nodejs1:14.20.0-2.module+el8.6.0+1004+df064614RLSA-2022:6448
Rocky Linux:8nodejs-nodemon0:2.0.19-2.module+el8.6.0+1003+ae94235aRLSA-2022:6448
Rocky Linux:8nodejs-nodemon0:2.0.19-2.module+el8.6.0+1046+80feca58RLSA-2022:6449
Rocky Linux:8nodejs-nodemon0:2.0.19-2.module+el8.6.0+1003+ae94235aRLSA-2022:6449
Rocky Linux:8nodejs-nodemon0:2.0.19-2.module+el8.6.0+1046+80feca58RLSA-2022:6448
Rocky Linux:9nodejs-nodemon0:2.0.19-1.el9_0RLSA-2022:6595
Rocky Linux:8nodejs-packaging0:23-3.module+el8.3.0+100+234774f7RLSA-2022:6448
Rocky Linux:8nodejs-packaging0:23-3.module+el8.7.0+1071+4bdda2a8RLSA-2022:6448
Rocky Linux:8nodejs-packaging0:23-3.module+el8.5.0+733+de4fee6cRLSA-2022:6448
Rocky Linux:8nodejs-packaging0:25-1.module+el8.6.0+1046+80feca58RLSA-2022:6449
Rocky Linux:8nodejs-packaging0:25-1.module+el8.5.0+702+221f14e6RLSA-2022:6449
Ubuntu:22.04:LTSnode-gotno fix listedUBUNTU-CVE-2022-33987
Ubuntu:24.04:LTSnode-gotno fix listedUBUNTU-CVE-2022-33987
Ubuntu:25.10node-gotno fix listedUBUNTU-CVE-2022-33987
Ubuntu:26.04:LTSnode-gotno fix listedUBUNTU-CVE-2022-33987
Ubuntu:26.10node-gotno fix listedUBUNTU-CVE-2022-33987
npmgot11.8.5GHSA-pfrx-2q88-qq97
npmgot12.1.0GHSA-pfrx-2q88-qq97

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References