Actively exploited · Published Aug 24, 2022 · Assigned by apple

CVE-2022-32893

High 8.8 Exploited

In plain English

A high-severity out-of-bounds write in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on August 18, 2022). The chance it is exploited in the next 30 days is estimated at 9.9% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)9.9%top 4.4% of all CVEs
Exploited in the wildYesCISA KEV since Aug 18, 2022
Attack toolingNoneno public tooling known

CISA guidance

Apply updates per vendor instructions.

Federal agencies must remediate by Sep 8, 2022.

Official description

An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1, Safari 15.6.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.36.7-1.el8_6ALSA-2022:6540
AlmaLinux:9webkit2gtk32.36.7-1.el9_0ALSA-2022:6634
AlmaLinux:8webkit2gtk3-devel2.36.7-1.el8_6ALSA-2022:6540
AlmaLinux:9webkit2gtk3-devel2.36.7-1.el9_0ALSA-2022:6634
AlmaLinux:8webkit2gtk3-jsc2.36.7-1.el8_6ALSA-2022:6540
AlmaLinux:9webkit2gtk3-jsc2.36.7-1.el9_0ALSA-2022:6634
AlmaLinux:8webkit2gtk3-jsc-devel2.36.7-1.el8_6ALSA-2022:6540
AlmaLinux:9webkit2gtk3-jsc-devel2.36.7-1.el9_0ALSA-2022:6634
Debian:12webkit2gtk2.36.7-1DEBIAN-CVE-2022-32893
Debian:13webkit2gtk2.36.7-1DEBIAN-CVE-2022-32893
Debian:14webkit2gtk2.36.7-1DEBIAN-CVE-2022-32893
Debian:12wpewebkit2.36.7-1DEBIAN-CVE-2022-32893
Debian:13wpewebkit2.36.7-1DEBIAN-CVE-2022-32893
Debian:14wpewebkit2.36.7-1DEBIAN-CVE-2022-32893
Rocky Linux:8webkit2gtk30:2.36.7-1.el8_6RLSA-2022:6540
Rocky Linux:9webkit2gtk30:2.36.7-1.el9_0RLSA-2022:6634
Rocky Linux:9webkit2gtk30:2.36.7-1.el9_1.1RLSA-2022:6634
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2022-32893
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2022-32893
Ubuntu:22.04:LTSwebkit2gtk2.36.7-0ubuntu0.22.04.1UBUNTU-CVE-2022-32893
Ubuntu:22.04:LTSwebkit2gtk2.36.7-0ubuntu0.22.04.1USN-5611-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2022-32893

Affected products (as reported)

VendorProductVersions
Apple Safari unspecified – before 15.6
Apple iOS and iPadOS unspecified – before 15.6
Apple macOS unspecified – before 12.5

Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References