Vulnerability · Published May 8, 2023 · Assigned by apple

CVE-2022-32885

High 8.8

In plain English

A high-severity out-of-bounds write in macOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.8%top 43.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A memory corruption issue was addressed with improved validation. This issue is fixed in iOS 15.6 and iPadOS 15.6, macOS Monterey 12.5, Safari 15.6. Processing maliciously crafted web content may lead to arbitrary code execution

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.40.5-1.el8ALSA-2023:7055
AlmaLinux:9webkit2gtk32.40.5-1.el9ALSA-2023:6535
AlmaLinux:8webkit2gtk3-devel2.40.5-1.el8ALSA-2023:7055
AlmaLinux:9webkit2gtk3-devel2.40.5-1.el9ALSA-2023:6535
AlmaLinux:8webkit2gtk3-jsc2.40.5-1.el8ALSA-2023:7055
AlmaLinux:9webkit2gtk3-jsc2.40.5-1.el9ALSA-2023:6535
AlmaLinux:8webkit2gtk3-jsc-devel2.40.5-1.el8ALSA-2023:7055
AlmaLinux:9webkit2gtk3-jsc-devel2.40.5-1.el9ALSA-2023:6535
Debian:12webkit2gtk2.40.1-1DEBIAN-CVE-2022-32885
Debian:13webkit2gtk2.40.1-1DEBIAN-CVE-2022-32885
Debian:14webkit2gtk2.40.1-1DEBIAN-CVE-2022-32885
Debian:12wpewebkit2.38.6-1DEBIAN-CVE-2022-32885
Debian:13wpewebkit2.38.6-1DEBIAN-CVE-2022-32885
Debian:14wpewebkit2.38.6-1DEBIAN-CVE-2022-32885
Ubuntu:22.04:LTSwebkit2gtk2.38.6-0ubuntu0.22.04.1UBUNTU-CVE-2022-32885
Ubuntu:22.04:LTSwebkit2gtk2.38.6-0ubuntu0.22.04.1USN-6061-1

Affected products (as reported)

VendorProductVersions
Apple macOS unspecified – before 12.5
Apple macOS unspecified – before 15.6
Apple macOS unspecified – before 15.6

Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References