Vulnerability · Published Aug 1, 2022 · Assigned by GitHub_M
CVE-2022-31177Possible to infer sensitive information through query strings in Flask-AppBuilder
Low 2.7
In plain English
A low-severity information exposure in Flask-AppBuilder from dpgaspar. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flask-AppBuilder is an application development framework built on top of Flask python framework. In versions prior to 4.1.3 an authenticated Admin user could query other users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users. This issue has been fixed in version 4.1.3. Users are advised to upgrade. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | flask-appbuilder | 4.1.3 | GHSA-32ff-4g79-vgfc |
| PyPI | flask-appbuilder | 4.1.3 | PYSEC-2022-247 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| dpgaspar | Flask-AppBuilder | < 4.1.3 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-32ff-4g79-vgfc x_refsource_CONFIRM
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v4.1.3 x_refsource_MISC