Vulnerability · Published Aug 3, 2022 · Assigned by GitHub_M

CVE-2022-31175Cross-site scripting caused by the editor instance destroying process in ckeditor5

Medium 5.8

In plain English

A medium-severity cross-site scripting in ckeditor5 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.8Medium
Exploit odds (30 days)0.9%top 40.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSckeditor3no fix listedUBUNTU-CVE-2022-31175
Ubuntu:24.04:LTSckeditor3no fix listedUBUNTU-CVE-2022-31175
Ubuntu:22.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2022-31175
Ubuntu:24.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2022-31175
Ubuntu:25.10ldap-account-managerno fix listedUBUNTU-CVE-2022-31175
Ubuntu:26.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2022-31175
Ubuntu:22.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2022-31175
Ubuntu:24.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2022-31175
Ubuntu:25.10request-tracker4no fix listedUBUNTU-CVE-2022-31175
Ubuntu:26.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2022-31175
npm@ckeditor/ckeditor5-html-embed35.0.1GHSA-42wq-rch8-6f6j
npm@ckeditor/ckeditor5-html-support35.0.1GHSA-42wq-rch8-6f6j
npm@ckeditor/ckeditor5-markdown-gfm35.0.1GHSA-42wq-rch8-6f6j

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor5 < 35.0.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L

References