Vulnerability · Published Sep 2, 2022 · Assigned by GitHub_M

CVE-2022-31152Synapse vulnerable to denial of service (DoS) due to incorrect application of event authorization rules

Medium 6.4

In plain English

A medium-severity security flaw in synapse from matrix-org. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)1.2%top 31.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix specification specifies a list of [event authorization rules](https://spec.matrix.org/v1.2/rooms/v9/#authorization-rules) which must be checked when determining if an event should be accepted into a room. In versions of Synapse up to and including version 1.61.0, some of these rules are not correctly applied. An attacker could craft events which would be accepted by Synapse but not a spec-conformant server, potentially causing divergence in the room state between servers. Administrators of homeservers with federation enabled are advised to upgrade to version 1.62.0 or higher. Federation can be disabled by setting [`federation_domain_whitelist`](https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html#federation_domain_whitelist) to an empty list (`[]`) as a workaround.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14matrix-synapse1.63.0-1DEBIAN-CVE-2022-31152
PyPImatrix-synapse1.62.0rc1GHSA-jhjh-776m-4765
PyPImatrix-synapse1.62.0PYSEC-2022-262

Affected products (as reported)

VendorProductVersions
matrix-org synapse < 1.62.0

Weakness: CWE-703 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H

References